Компонента 1С. Инструкция по использованию

Содержание:

Инициализация начальных переменных

Подключение

Взаимодействие с терминалом

Ответ от терминала поступит через внешнее событие, т.е. обрабатывать его необходимо в процедуре
ОбработкаВнешнегоСобытия(Источник, Событие, Данные):

Получение и обработка результатов (в случае успешного выполнения команд):

Инициализация

Перем mt01;

Процедура ПриНачалеРаботыСистемы()  
    Попытка 
        ПодключитьВнешнююКомпоненту("AddIn.mt01"); 
        mt01 = новый COMОбъект("AddIn.mt01"); //Для 1С 7.7: mt01 = СоздатьОбъект("AddIn.mt01");
        mt01.SetName("mt01"); 
        mt01.SetKey("XXXX-XXXX-XXXX-XXXX-XXXX"); 
        mt01.SetAddress("192.168.1.2"); 
        mt01.SetConnectionType("0");        
        mt01.Connect();
        Сообщить("Состояние соединения: " + mt01.Connected());
    Исключение
        Сообщить("Ошибка при подключении компоненты mt!" + ОписаниеОшибки());
    КонецПопытки;
КонецПроцедуры

Обработка внешнего события

Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)   
    Если (Источник = "mt01") Тогда
        Если (Событие = "GetWeight") Тогда
            Если (Данные = "1") Тогда           
                Сообщить("Gross: " + mt01.GetGross("1") + "; Tare: " + mt01.GetTare("1") + " " + mt01.GetUnit("1") + " ;Status: " + mt01.GetStatus("1"));
            КонецЕсли;          
        КонецЕсли;  
        Если (Событие = "Connected") Тогда
            Если (Данные = "1") Тогда           
                Сообщить("Весы подключены");
                Попытка 
                    mt01.GetWeight();
                Исключение
                    Сообщить("Ошибка вызова GetWeight: " + ОписаниеОшибки());
                КонецПопытки;
            Иначе
                Сообщить("Весы отключены");     
            КонецЕсли;              
        КонецЕсли;
    КонецЕсли;   
КонецПроцедуры